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Updating the previous edition's tips to include features in Office 365 and Excel 2019, this new
edition of MrExcel's popular software guide even incorporates suggestions sent in by readers.
Each featured topic has a problem statement and description, followed by a broad strategy for
solving the problem. MrExcel then walks readers through the specific steps to solve the issue.
Alternate strategies are also provided, along with common scenarios that trip up users, leaving
readers with not only answers to their specific dilemmas but also new and quicker ways to use
formulas and spreadsheets.

About the AuthorBill Jelen is the host of www.MrExcel.com, Microsoft MVP, and he writes the
monthly Excel column for Strategic Finance Magazine. He is the author of 54 books about Excel.
--This text refers to the paperback edition.
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LaSasso, Jeffrey Latsko, Stacey Lawrence, Rob Leblanc, Johann Manjarrez Ledesma, Paul
Leonard, Mark Leskowitz, Laura Lewis, Rene Lie, Bei Lin, Crystal Long, Sérgio Nuno Pedro
Lopes, Rick Lubinski, Stuart Luxmore, Patrick C Lynch, Carl MacKinder, Sarker Ashek Mahmud,
Roseanne Maish, Romas Malevicius, Micahel Maramzin, Dan Marks, Al Marsella, Joe Marten,
Giles Martin, Real Mayer, Dan Mayoh, Sally McBride, Wendy McCann, Bethany McCrea, Bill
McDiarmid, Thomas McGough, James McKay, Wyatt McNabb, Sergio Melendez, Isabel
Mendoza, David Merkel, Dakshesh Mewada, John Meyer, L. Michael, Henning Mikkelsen, Dan
Miller, Mark Miller, Richard Miller, Susan Miller-Wells, Greg Montgomery, Mikal Moore, Terry
Moorehouse, Ali Mozaffari, Isabel Mrndoza, Kyle Munson, Lucy Myers, Shawn Nelson, Matthew
Netzley, Susan Nicholls, John Nichols, Susan Nichols, Dara Nolan, Bill Northrup, Dolores Oddo,
Richard Oldcorn, Jeremy Oosthuizen, and Brent Oswald.Also from Milind Padhye, Andre
Pearson, Michael Pennington, Mario Perez, Dominik Petri, Matthew Pfluger, E. Phillips, Pete
Pierron, Stephen Pike, David Plante, Bill Polen, Dave Poling, Sergiy Polovy, Nadar Ponnuturai,
Brenton Prior, John Pyskaty, Blaine Raddon, Bob Ragland, Jerry Ransom, Fabien Raynaud,
Sandra Renker, Greg Richmond, Russell Richter, Gary Ritter, Bill Robertson, Jamie Rogers,
Chris Rohde, Julie Rohmann, Margaret De La Rosa, Vlad De Rosa, Jim S. Rose, Dave
Rosenberger, David Rosenthal, Chuck Ross, Hamilton Rozario, Fabian Ruales, Peter Rutter,



Marty Ryerson, Tom Saladin , Abdul Salam, Dion Sanchez, Ricardo Santiago, Jack Santos,
Lorna A. Saunders, Steve Scaysbrook, Julie Scheels, Lori Schleuter, Randal L. Schwartz, Diane
Seals, Robert D Seals, Mark Secord, Ashokan Selliah, Denison Seminar, Bryony Seume, Ewan
Shannon, Uma Sharma, Wayne Shelton, Ute Simon, Brett Simpson, Manfred Simrodt, Loh Seok
Siong, Don Smith, Chris Sours, Mark Spratt, Daan Sprunken, Harold Starr, Shlomo Stern, Clay
Sullivan, Kevin Sullivan, Keith Sumrall, Seiichi Suzuki, Bill Swearer, Mike Syracuse at the
Globetrotters, Brian Taylor, James Tays, David Teague, Martin Thelfer, Sarah Thomas, Denise
Thomson, Bob Tiller, Mark Tittley, Richard Todd, Michael Tucker, Mr. Andrew Tucker, Breck
Tuttle, Bob Umlas, Vaibhav Vaidya, Claude Van Horn, Geoff Vautier, Dinesh Vijaywargiay,
Thomas Vogel, J. B. Voss, Wiebe van der Waals, Grant Wang, Tim Wang, Kim Wasmundt, Pam
Waymack, Rebecca Weing, Susan Wells, John Wendell, Douglas A. Wesney, Justin White,
Neville White, Gary Whiteford, Scott Whyte, Mack Wilk, Shaun Wilkinson, Bill Wood, Chris
Wright, Yvonne at the AEAP meeting, Dick Yalmokas, Pat Yong, Kathy Zdarstek, and Deb
Zurawski. Many others made a suggestion during a seminar, but all I can remember is
something like “Derek in Row 6 in Springfield”, “Dan in Philly”, “that nice lady on the right side in
Kent, Ohio”, and others. If you own an Excel Master pin and I didn’t list your name, please e-mail
me so I can correct the omission.At Microsoft, the Excel, Power Pivot, Power Map, Power Query,
Power BI and Excel Web App teams keeps adding new features to Excel. At the IMA, Kathy
Williams and Christopher Dowsett keep my Strategic Finance articles in shapeMy sister Barb
Jelen likely packed and shipped the book if you ordered it directly from MrExcel.com.My family
were incredibly accommodating. Thanks to Mary Ellen, Josh & Zeke.ForewordIam a comic book
superhero.At least, I play one at work. As the mighty man of macro, I have the coolest job in
town: playing MrExcel, the smartest guy in the world of spreadsheets.Well, yes, that is a lot of
hype. I am not really MrExcel. In fact, there are so many different ways to do the same thing in
Excel that I am frequently shown up by one of my own students. Of course, I then appropriate
that tip and use it as my own!I have incorporated some of these discoveries in a pretty cool 3.5-
hour seminar titled Power Excel with MrExcel. This is amazing stuff—like pivot tables, filters, and
automatic subtotals. I love to be in front of a room full of accountants who use Excel 40+ hours a
week and get oohs and ahhhs within the first few minutes. I have to tell you, if you can make a
room full of CPAs ooh and ahh, you know that you’ve got some good karma going. At that point, I
know it will be a laugh-filled session and a great morning.One of these classes, which I was
presenting at the Greater Akron Chamber, provided the Genesis moment for this book. One of
the questions from the audience was about something fairly basic. As I went through the
explanation, the room was silent as everyone sat in rapt attention. People were interested in this
basic tip because it was something that affected their lives every day. It didn’t involve anything
cool. It was just basic Excel stuff. But it was basic Excel stuff that a room full of pretty bright
people had never figured out.Think about how most of us learned Excel. We started a new job
where they wanted us to use Excel. They showed us the basics of moving around a spreadsheet
and sent us on our way. We were lucky to get 5 minutes of training on the world’s most complex



piece of software!Here is the surprising part of this deal. With only 5 minutes of training, you can
use Excel 40 hours a week and be productive. Isn’t that cool? A tiny bit of training, and you can
do 80% of what you need to do in Excel.The problem, though, is that there are lots of cool things
you never learned about. Microsoft and Lotus were locked in a bitter battle for market share in
the mid-1990s. In an effort to slay one another, each succeeding version of Excel or Lotus 1-2-3
offered incredibly powerful new features. This stuff is still lurking in there, but you would never
know to even look for it. My experience tells me that the average Exceller is still doing things the
slow way. If you learn a just couple of these new tips, you could save 2 hours per week.This book
talks about 667 of the most common and irritating problems in Excel. You will find each of these
667 items (which you have been stumbling over ever since your “5 minutes of training”) followed
by the solution or solutions you need to solve that problem. A lot of these topics stem from
questions sent my way in seminars I’ve taught. They may not be the coolest tips in the whole
world, but if you master even half of these concepts, you will be smarter than 95% of the other
Excellers in the world and will certainly save yourself several hours per week.Most of the 667
topics in this book presents a problem and its solution. There are plenty of books that go through
all of Excel’s menus in a serial fashion. (I’ve written a few). The trouble with those books is that
you have no clue what to look up when you are having a problem. No one at my dinner table has
ever used the word concatenation, so why would anyone ever think of looking up that word when
they want to join a first name in column A with the last name in column B? (see"Join Two Text
Columns" on page 92)Despite its size, this book is a quick read. You can probably skim all 667
topics in a couple of hours to get a basic idea of what is in here. When you face a similar
situation, you can find the appropriate topic, apply it to your own problem, and you should be all
set.This book takes a different approach than others I have tried to use. I am MrExcel, but I am
hopelessly clueless with Photoshop. Wow! This is an intimidating program. I own a ton of books
on Photoshop. There must be a bazillion toolbars in there. Most books I pick up tell me to press
the XYZ button on the ABC toolbar. I can’t even begin to figure out where that toolbar is. I hate
those books. So, my philosophy here is to explain the heck out of things. If you find a topic in this
book in which I tell you to do something without explaining how to do it, please send me an e-
mail to yell at me for not being clear.How to Use This BookEach topic starts with a problem and
then provides a strategy for solving the problem. Some topics may offer additional details,
alternate strategies, results, gotchas, and other elements, as appropriate to the topic. Each
chapter wraps up with a summary and a list of any Excel commands or functions used in the
chapter. The screenshots are a mix of 2010, 2013, 2016, and 2019, depending on the age of the
tip.Starting with Excel 2007, Microsoft has organized the ribbon into a series of tabs: the Home
tab, the Insert tab, the Page Layout tab, and so on. Within each tab, Microsoft has organized
icons into various groups. On the Home tab, for example, there are groups for Clipboard, Font,
Alignment, Number, Styles, Cells, and Editing. In this book, if I want you to choose the Delete
icon from the Cells group on the Home tab of the ribbon, I say, “Choose Home, Delete.” The
other option is to say “Choose Home, Cells, Delete,” but you never actually choose Cells; it is



merely a label, so I generally do not mention the group when I write about a command.Gotcha:
When you are working on a chart, Excel adds two new tabs for charts, as shown in Figure 1.
(These tabs do not appear when you are not working with charts.) You might see Excel Help
referring to the “Chart Tools | Format tab”. I won’t don’t do this. If the topic is talking about charts,
I am going to assume that you are actually working on a chart, and I will refer to the Format tab
instead of the Chart Tools | Format tab.Figure 1 This book refers to the Chart Design or Format
tabs.Gotcha: Some of the icons on the ribbon tabs have two parts: the main icon and a
dropdown. You can see the dividing line between the two parts only when you hover the mouse
over the icon. When you need to click the icon itself, this book uses the name of the icon. For
example, when you need to select the Paste icon from the Home tab, the text says to choose
Home, Paste. When you need to select something from a dropdown under an icon, the text
specifies dropdown; for example, when you need to select Paste Values from the Paste
dropdown, this book tells you to choose Home, Paste dropdown, Paste Values.In addition to the
tabs across the ribbon, many dialog boxes contain a number of tabs. For example, if you click
the Print Titles icon on the Page Layout tab, Excel displays the Page Setup dialog, which has
four tabs as shown in Figure 2. If I want you to choose the Header/Footer tab of the dialog, I
might write, “Select Page Layout, Print Titles, Header/Footer, Custom Header.” Or, I might say,
“From the Page Layout tab of the ribbon, select Print Titles. In the Page Setup dialog, choose the
Header/Footer tab and then click Custom Header.”Figure 2 Select Page Layout, Print Titles,
Header/Footer, Custom Header.Gotcha: In some dialog boxes, Excel has abandoned tabs
across the top and used a left navigation instead. See the Excel Options dialog shown in Figure
3. I might write File, Options, Data, Edit Default Layout to refer to the Data category in the Excel
Options dialog.Figure 3 In this dialog, the tabs move from the top to the left.This book uses the
term press to refer to keyboard keys (for example, “press Enter,” “press F2”). It uses the term
click to refer to buttons and other items you click onscreen (for example, “click OK,” “click the
Paste icon”). It uses the term select or choose to refer to selections from the ribbon and option
buttons and check boxes within dialogs (for example, “select the Home tab,” “select the No Fill
option”).Additional ResourcesThe files used in the production of this book are available for
download at mrx.cl/pe19files. Most topics in the book are covered on the free MrExcel podcast.
Visit www.mrexcel.com for details on how to get the podcasts for free.Quick Start - If You are
New to ExcelIf you consider yourself new to Excel and don’t know where to start, here are some
great topics for you.Keep favorites in the Recent Documents List - page 18Get finished
worksheets from Office.com - page 22See Headings as You Scroll - page 28Zoom with the
mouse - page 33Mix formatting within a cell - page 42Use the Fill Handle to enter months - page
42Fit a report to one page wide - page 57Add a watermark - page 58Excel can read to you -
page 66Entering Formulas - page 75Why dollar signs in formulas - page 80Total without
formulas - page 89Join Two Text Columns - page 92Clean data with Flash Fill - page 95Discover
new functions - page 115Excel as a calculator - page 119Loan payments - page 132Calculate a
Percentage of Total - page 146Making decisions with IF - page 158Match records with



VLOOKUP - page 170Dice in Excel - page 199How to avoid blank columns - page 270Add
hundreds of subtotals at once - page 287Summarize a data set in 6 clicks - page 335Help your
manager visualize numbers - page 518Show Checkmarks in Excel - page 525Tame your
hyperlinks - page 561Circle a cell - page 579Plot your Excel data on a map - page 463Use
Document Themes - page 556Draw Business Diagrams - page 587Add a dropdown to a cell -
page 599Quick Start - For Power ExcellersIf you think you know Excel really well, I bet you will
find some gems in these topics:Open Excel with Ctrl+Alt+X - page 23Never change your
margins again - page 26Ctrl+Backspace brings current cell in to view - page 33Amazing way to
paste values - page 34Quickly rearrange columns - page 37Fill 1 to 100000 - page 44F4
Repeats last command - page 68See all named ranges - page 88Concatenate several cells -
page 93Formula to put worksheet name in a cell - page 105Intersection for 2-way lookup - page
123Back into an answer - page 133Replace IF with Boolean logic - page 159Find the second
largest value - page 199The real benefit of tables - page 212Trace formulas - page 213See key
cells from many worksheets in one place - page 216Analyze every date between 2 cells - page
234Track negative time - page 240Filter by selection - page 280Total just the filtered rows - page
282Copy just the subtotals - page 291Sort the subtotals - page 293Remove duplicates - page
317Show Yes/No in a pivot table - page 351AutoFilter a pivot table - page 370Generate reports
for every customer without a macro - page 374Pivot table template - page 358Compare two lists
faster - page 404Clean data with Power Query - page 410No more VLOOKUPs with Power Pivot
- page 427Asymmetric pivot tables for past actuals and future plan - page 435100 million rows
with Power Pivot - page 425Add new data to a chart - page 475Easy combo charts - page
489Hundreds of tiny charts in seconds - page 512Sorting Left to Right - page 541Pop-up Picture
- page 571Paste a live picture of cells - page 571Get SmartArt content from cells - page
595Quick Start - What’s NewHere are a few amazing newer features in Excel:Geography, Stock,
and Exchange Rate Data Types - page 286Dynamic Arrays: Formulas Can Now Spill - page
289Use Column From Examples to Learn Power Query Formulas - page 440Get Ideas from
Artificial Intelligence - page 538Use Filled Map Charts - page 550Part 1 The
ExcelEnvironmentWhy Does Office 365 Have Better Features?Problem: I have Geography and
Stock Data Types at home, but not at work, What is going on?Strategy: You have Office 365 at
home. Buy agreeing to pay a monthly or annual fee for Office, you are getting frequent updates
and new features. If someone buys Office 2019, they get a few new features, but they will never
get the new monthly features. The days of the annual Service Pack are gone.In the good old
days (2003, 2007, 2010, 2013), Microsoft would spend three years putting new features into
Office and the customers would invest $400 every other release. Now, Microsoft wants you to
rent your copy of Office. Pay $10, $12, or $15 a month or $99 a year and you will get monthly
updates.I originally said that I would never rent Office. But then Microsoft started putting must-
have features in Office 365 and not in the regular release of Office, so now I can see that renting
Office 365 is the only logical choice. With Office 365, you will get to use mobile versions of Excel
on an iPad, iPhone or Android device.Should I Buy Office 2019 or Subscribe to Office 365?



Problem: The Office 365 website is super-confusing. I don’t want to buy the wrong
version.Strategy: Office 365 is the only way to get you the full version of Excel. The $99 a year
plan allows you to install Excel on six computers including a Mac. You might have to use Surveys
instead of Forms and will be sent to the consumer OneDrive instead of OneDrive for Business.
But it will get you all of the Excel that you need.On the other hand, if you buy Office 2019, you
will be missing many features: Geography & Stock data types, Artificial Intelligence with Ideas,
Dynamic Arrays such as SORT, FILTER, UNIQUE and SEQUENCE. .How Can I Use Excel on
Dual Monitors?Problem: Why is it so hard to use Excel on two monitors?Strategy: This problem
is fixed in Excel 2013. Every Excel workbook gets its own window, complete with a ribbon and
formula bar. Open two workbooks, drag on to the other monitor and you will have 36 linear
inches of Excel.In Excel 2010, you have to use this hack: You can hold down the Shift key while
opening Excel to create a second instance of Excel. Downside: you can not copy formulas from
one instance to the other.How Can I Open The Same Workbook Twice?Problem: I used to open
two copies of the same workbook. I could select cells in copy B, see the total in the status bar,
and then type that information in to a different place in copy A. Now that Excel opens every
workbook in a new window, I can not open the same workbook twice.Strategy: Open the first
instance of the workbook. Then, force Excel to open in a new instance by holding down the Shift
key while opening Excel. In the second instance of Excel, use File, Open to open the workbook
again.Find Icons on the RibbonProblem: I know a certain feature exists in Excel, but I can not
find it in the Ribbon.Strategy: Use the new Tell Me feature in Excel 2019. Located to the right of
the last tab in the Ribbon, a box with a lightbulb and “Tell Me What You Want To Do” appears.
Click in the box and type the name of the feature. A selectable list of commands appears.Figure
4 These commands are usually hidden in Commands Not in the Ribbon, but are now
available.Gotcha: If you are in Excel 2013 and don’t have Tell Me, open an Excel workbook at
Office.Live.Com and use the Tell Me command in Excel Online.Where is File, Exit?Problem:
What happened to the old Exit command?Strategy: Although Exit is missing from the File menu
in 2013-2019, you can use Alt+F, X to invoke the Exit command. Or, add Exit to the Quick
Access Toolbar.1. The top-left corner of Excel contains a tiny strip with icons for AutoSave, Save,
Undo, and Redo. Right-click that strip and choose Customize Quick Access Toolbar.2. The top
left dropdown starts with Popular Commands. Open that dropdown and choose All Commands.
You now have an alphabetical list of 2400+ commands.3. Scroll through the list to find Exit.
When you find your command, click the command. Click the Add>> button in the center of the
screen to add the command to the Quick Access Toolbar.Where Are My Macros?Problem: Did
Microsoft abandon the macro facility? Where are the buttons to record a new macro, run a
macro, and so on? How do I get to the Visual Basic Editor?Figure 5 A subset of macro
commands are available on the View tab.Strategy: Most of the macro icons are hidden. Three
macro options appear on the extreme right end of the View tab. You use the Macros dropdown to
view macros, record a macro, or use relative references while recording a macro.To access the
rest of the macro functionality, you need to enable a hidden Developer ribbon tab. Choose File,



Options, Customize Ribbon. Add a checkmark next to Developer. The Developer tab offers
macro commands, buttons from the former Forms toolbar and Control Toolbox, and XML
settings.Figure 6 Microsoft disables the Developer tab by default.Figure 7 If you use macros,
enable the Developer tab.Additional Details: When you are recording a macro, instead of seeing
the Stop Recording icon floating above the Excel window, you now see it in the Status Bar, next
to Ready.Figure 8 Once you’ve recorded a macro, the Stop and Record buttons will appear next
to Ready.The same area of the status bar includes a Record Macro button when you are not
recording a macro. However, because there is not a Relative References button, you cannot
effectively record macros without using either the View tab or the Developer tab of the
ribbon.Collapse the Search BoxProblem: Why is the Search box so large? I never use
this.Strategy: Starting in the spring of 2019, you can collapse it to a small icon. Use File, Options,
General.Figure 9 Collapse the Search Box to a tiny icon.Customizing the RibbonProblem: I want
to customize the ribbon.Strategy: Ribbon customizations in Excel are weak compared with the
customization capabilities in Excel 2003. You might feel like the Pivot Table command belongs
on the Data tab rather than on the Insert tab. You can add a new group to the Data tab to hold
the pivot table icons. First, look at the ribbon and decide where you want the new group to
appear. Perhaps a good location would be between the Sort & Filter group and the Data Tools
group.Figure 10 Decide where you want the new group to appear.Right-click anywhere on the
ribbon and choose Customize the Ribbon.Figure 11 Right-click the ribbon to access this
menu.The Customize dialog contains two large list boxes. You will first be working with the list
box on the right side of the screen. Expand the plus sign next to the Data entry to see the groups
on the Data tab. If you want a new group to appear after the Sort & Filter group, click Sort &
Filter, and then click the New Group button below the list box.Figure 12 Choose where the new
group should go.Excel adds a new group with the name of New Group (Custom). Click the
Rename button below the list box.Figure 13 Choose to rename the groupType a new name in
the Rename dialog. Also, choose an icon. This icon will appear only when the Excel window gets
small enough to force the group into a dropdown, as shown later in Figure 18.Figure 14 Type a
new name and choose an icon to represent the group.Note: The 180 icons available are a far cry
from the 4096 icons available in Excel 2003. As I pointed out at the beginning of this chapter,
toolbar customization took a giant step backward after Excel 2003.After renaming the new group
in the list box on the right side, it is time to turn your attention to the list box on the left side. It
starts out showing Popular Commands. Use the dropdown above the left list box to change from
Popular Commands to All Commands.Scroll down to the commands starting with Pivot. You will
see a confusing array of commands. Click the first PivotTable icon, and click the Add button in
the center of the screen. Click the second PivotChart icon, and then click the Add button. Click
PivotTable and PivotChart Wizard, and then click the Add button.Figure 15 Choose icons to add
to the new group.It is sometimes difficult to figure out which icons you want. There are two icons
that say PivotTable. The first icon is simply an icon. The second icon is an icon with a rightward-
facing triangle on the right side of the list box. That triangle indicates that the second icon is



actually a dropdown that leads to more choices. That second PivotTable dropdown icon is the
icon at the bottom half of the Insert tab’s Pivot Table group. It opens to enable you to choose
between PivotTable and PivotChart. You might prefer to use that icon instead.Two PivotChart
icons are available. Hover over each icon to see that the first one is the PivotChart icon available
on the PivotTable Tools Options tab. You will also see that the second icon is the one on the
Insert tab. The first PivotChart icon will be grayed out unless you are in a pivot table. The second
PivotChart icon is the one that is used to create a new pivot chart from a data set.This figure
shows the resulting group on the Data tab.Figure 16 The custom group is added to the ribbon.If
you are wondering why you had to choose an icon back in Figure 14, it is for people who have
the Excel window resized to a narrower width. If you make your Excel window narrower, the
custom group will eventually get squished down to a single dropdown. Your icon will appear on
that dropdown, as shown here.Figure 17 The icon from Figure 14 shows with a smaller window
size.Note back in Figure 10 that the Sort icon appears as a large icon with a caption and that the
AZ and ZA icons appear as small icons without a caption. How can you specify that the pivot
table icon should be large and the pivot chart and wizard icons should be small? You can’t. At
least not with the Excel interface.If you want to start writing some XML and VBA, you can gain
control over the size and images used in the ribbon. For an excellent book on this daunting task,
look for RibbonX: Customizing the Office 2007 Ribbon by Robert Martin, Ken Puls and Teresa
Hennig. Or, check out the Ribbon Commander utility described at http://mrx.cl/2dbS4Js.I find
that I spend most of my time on either the Home or the Data tab. If I could combine the left side
of the Home tab with the right side of the Data tab, plus pivot tables, I would probably be able to
spend all my time on one tab.This figure shows a new MrExcel tab that reuses groups from other
ribbon tabs to build a new tab.Figure 18 The MrExcel tab is a custom tab with my favorite
groups.The general steps for creating a new ribbon tab are as follows:1. Right-click the Ribbon
and choose Customize the Ribbon.2. Click New Tab at the bottom right of the dialog.3. Click
Rename and give the tab a name.4. Use the Up and Down buttons at the right side of the dialog
to move the new tab into the proper location.5. From the left dropdown, choose Main Tabs.6. In
the left dropdown, expand an existing tab and find an existing group that you want to add to your
new tab. Click that group and click Add.7. Repeat step 6 to add additional groups.8. You can
reuse a custom group that you created previously. In the left dropdown, choose Custom Tabs
and Groups. You can move the Pivot Table (Custom) tab created earlier in this chapter onto your
new ribbon tab.9. Click OK to finish customizing the ribbon tab.Go WideProblem: My ribbon
looks different than my co-workers.Strategy: Invest in a wide-screen monitor. The Excel
experience dramatically improves at a 1440x900 or 1920x1080 resolution.When you reduce the
size of the Excel window, Excel automatically starts consolidating ribbon options into smaller
icons and then groups. The next four figures show details of the Home tab of the ribbon at
different sizes.Figure 19 At 1920 wide, five columns of the gallery are shownFigure 20 At a
smaller screen, the cell styles gallery is a dropdown.Figure 21 Eventually, the entire Styles group
becomes a dropdown..Figure 22 If the Excel window is too small, the Ribbon disappears.If you



are the go-to person for solving Excel problems and you are helping a co-worker over the phone
without using GoToMeeting, there will be some frustration as you tell them to look for the Bad,
Good, Neutral tiles and they can only see a Styles dropdown.Minimize the Ribbon to Free Up a
Few More RowsProblem: The ribbon is taking up a lot of real estate at the top of my screen. It
distracts me. I spend 99% of my Excel time in the grid, so I don’t need to see the ribbon all the
time.Strategy: You can minimize the ribbon, reducing it to a simple line of Home, Insert, Page
Layout, Formulas, and so on.To minimize the ribbon, you can either press Ctrl+F1 or right-click
anywhere on the ribbon and then choose Minimize the Ribbon. You can also use the carat (^)
icon at the right edge of the ribbon.Additional Details: When you either click a ribbon tab with the
mouse or use an Excel shortcut key, the ribbon will temporarily reappear. When you select the
command from the ribbon, it will minimize again.Double-click any ribbon tab to permanently exit
minimized mode. Or, open any ribbon tab and then use the thumbtack icon on the right edge of
the ribbon.Use a Wheel Mouse to Scroll Through The Ribbon TabsIf you point your mouse at the
ribbon and scroll the wheel, you will quickly move from Home to Insert to Page Layout and so
on.Why Do The Charting Ribbon Tabs Keep Disappearing?Occasionally, new tabs will appear
on the right side of the ribbon. These tabs appear when the current selection includes SmartArt
graphics, charts, drawings, pictures, pivot tables, pivot charts, worksheet headers, tables, ink, or
when you are in the legacy Print Preview mode.These new tabs will stay visible as long as the
object stays selected. If you click outside of your pivot table or chart, the tabs will disappear. If
you are looking at an object and cannot find the tools necessary to edit the object, click the
object to bring the tools back.Use Dialog Launchers For More ChoicesProblem: It seems like
there should be more choices than what is showing on the ribbon. Where is Center Horizontally
in the ribbon?Strategy: Many groups in the ribbon contain a tiny icons called dialog launchers.
You can click an icon to open a dialog with more choices. This figure shows an example of a
dialog launcher.Figure 23 Take me back to the old dialog.Additional Details: It is difficult to
describe the dialog launcher icon. If you enlarge the icon, you can see that it looks like the top-
left corner of a square with an arrow pointing down and to the right. I am sure there is some
artistic rationale why these pixels mean “launch the full dialog ,” but I can’t figure it out.Icon,
Dropdowns, and HybridsProblem: The ribbon introduces several new types of controls.In this
figure, the Table and Pictures icon will invoke a command. The Shapes and Screenshot icons
are dropdowns that lead to a flyout menu.Figure 24 A mix of dropdowns, icons, and
hybrids.However, the Paste icon is actually two icons. The top half will do a default Paste. The
bottom half leads to a flyout. You can’t really tell which icons are a hybrid of icon and dropdown
until you hover over the icon with your mouse.Figure 25 When you hover, a horizontal line
divides the icon.The other new type of control in the ribbon is a gallery with three arrows at the
right side. The first and second arrows in the gallery will scroll through choices one row at a
time.If you click the bottom arrow, the gallery will fly open to reveal all of the choices.Figure 26
Galleries have three arrows on the right edge.Additional Details: Several icons have an upper
(icon) half and a lower (dropdown) half:Paste on the Home tabInsert on the Home tabDelete on



the Home tabBring Forward on the Page Layout tabSend Backward on the Page Layout
tabAutoSum on the Formulas tabData Validation on the Data tabMacros on the View tabFigure
27 Use bottom arrow to open the gallery.Zoom is at the BottomProblem: Starting in Excel 2007,
all commands in Office are supposed to be at the top of the screen. Don’t miss the View and
Zoom commands at the bottom right of the window.Figure 28 Control view and zoom in lower
right.Strategy: The icons in the lower-right corner of the screen control the zoom and switch
between Normal view, Page Break Preview, and Page Layout view.The zoom slider gives you
one-click access to change the zoom from 10% up to 400%. This is easier to use than the old
Zoom dropdown on the Standard toolbar. You just click the + icon at the right to increase the
zoom in 10% increments. You click the, icon at the left to decrease the zoom in 10% increments,
or you can simply drag the zoom slider to any spot along the continuum. To access the legacy
Zoom dialog, click on the digits in the zoom percentage.As in past versions of Excel, the
quickest way to zoom in Excel is to use the wheel mouse. You hold down the Ctrl key while you
scroll the wheel on your mouse forward to zoom in or backward to zoom out.At a 400% zoom,
you can get an ultra-close look at the detail of Excel’s High-Low-Close stock chart to see that
they really don’t draw the left-facing Open symbol.Figure 29 At 400% zoom, you can see tiny
details in charts.Figure 30 At 10% zoom, view hundreds of pages at once.At a 10% zoom, you
can get a view of your whole document - more than 21,000 cells.The other three buttons in the
lower-right corner of the screen switch between Normal view, Page Break Preview, and the new
Layout view. You can read about the cool Layout view in "How to Print Page Numbers at the
Bottom of Each Page" on page 56.Make Your Most-Used Icons Always VisibleProblem: With the
ribbon, I can only see one-seventh of the icons at any one time. I find that I spend a lot of time on
the Data tab, but I annoyingly have to keep switching back to the Home tab. Does Microsoft
really think this is better?Strategy: Microsoft provided the Quick Access toolbar to address this
problem. You can add your favorite icons to the Quick Access toolbar and then, because the
Quick Access toolbar is always visible, you can invoke your most-used icons without having to
switch ribbon tabs so frequently.The Quick Access toolbar (QAT) starts out as a small bar with
the icons AutoSave, Save, Undo, and Redo. It initially appears above the ribbon, above the File
menu, as shown here.Figure 31 The QAT starts with five icons.If you right-click the Quick
Access toolbar, you can choose to move it below the ribbon. This gets your most used icons
closer to the grid and provides room for a few more icons.A dropdown at the end of the QAT
offers several popular commands that you can add to the toolbar.For twenty years, Ctrl+P would
print your document. Starting in Excel 2010, Ctrl+P takes you to the Print panel in the Backstage
view. You then have to click the Printer icon to actually print. Again, this is one more mouse click
than previous versions. Add the new Quick Print icon to the QAT if the extra step annoys
you.Figure 32 Add these popular commands to the QAT.When you find yourself using a ribbon
icon frequently, you can right-click the icon and choose Add to Quick Access Toolbar, as shown
below. This is the easiest way to customize the Quick Access toolbar.Figure 33 Right-click a
command and add to QATGotcha: Some of the icons look similar to one another when moved to



the Quick Access toolbar. For example, Goal Seek, Go To Special and Scenario Manager use a
green crystal ball icon. Unless you are a fortune teller, hover over each icon to see its ToolTip
and tell which is which.Figure 34 The green crystal ball is used for too many
commands.Additional Details: You can right-click the Quick Access toolbar and choose
Customize Quick Access Toolbar to reach the full-featured dialog shown in Figure 35. The dialog
offers a dropdown of categories on the left. Below this dropdown is a list of icons from the
category. Here’s how you use this dialog:You can select an icon on the left and click the Add
button to add the icon to the Quick Access toolbar.You can select an icon on the right and click
the Up or Down buttons to re-sequence the icons on the Quick Access toolbar.You can click the
Reset button near the bottom to undo all your customizations and restore the Quick Access
toolbar to the initial three buttons.You can use the top-right dropdown to say that certain icons
should be assigned to the current workbook. Most Quick Access toolbar icons apply to every
workbook. However, you can have 10 icons for every workbook and then add 3 additional icons
for each specific workbook. The 10 global icons appear first, followed by the 3 local icons.You
can organize your icons into logical groups and then add a separator between groups. To do
this, you click the <Separator> item at the top of the left list and then click Add to add a vertical
line between icons.You should pay particular attention to the category Commands Not in the
Ribbon. If one of your favorite Excel 2003 or earlier commands is in this category, Microsoft
completely left it out of the ribbon. The only way to access the command is by adding it to the
Quick Access toolbar or a new group in a customized Ribbon.Figure 35 You can find all
commands here.The Excel 2003 Alt Keystrokes Still Work(If You Type Them Slowly
Enough)Problem: I can’t find anything on the ribbon. I used to use a lot of keyboard shortcuts.
For example, I often used Alt+E+I+J to invoke Edit, Fill, Justify. Microsoft completely eliminated
the Edit menu, so what shortcuts do I use now?Strategy: Your old keystrokes still work; you just
have to invoke them a bit more slowly than usual.Many people who used the old Excel regularly
memorized a few Alt keyboard shortcuts. My favorites, for example, are Alt+E+S+V for Edit,
Paste Special, Values, Alt+O+C+A for Format, Column, AutoFit Selection, and Alt+E+I+J for
Edit, Fill, Justify.In Excel, any Excel 2003 keyboard shortcuts you memorized between the Edit
and Window menus continue to work. A few of the keyboard shortcuts from the File menu still
work, but others do not.To use an Excel 2003 shortcut, you press Alt and the first letter rapidly. If
you press Alt and E, V, I, O, T, D, or W, Excel will display a ToolTip above the ribbon that says
Office 2003 Access Key. At this point, you can continue typing the rest of the Excel 2003 menu
shortcut. In this figure, the ToolTip shows that Alt+E+I has been typed, which is two-thirds of the
shortcut to reach Edit, Fill, Justify.Figure 36 Old Alt shortcuts still work.When you type the final
bit of the shortcut, Excel closes the ToolTip and performs the command.Gotcha: Excel doesn’t
provide any feedback about what command you are typing. In Excel 2003, you could look at the
Data menu to learn what to do after typing Alt+D, but Excel doesn’t offer this feature.Gotcha: It
takes Excel a fraction of a second to display the ToolTip. I find that I have to pause briefly after
typing Alt plus the first keystroke. For example, if I rapidly type Alt+O+C+A to invoke Format,



Column, AutoFit Selection, about half the time, Excel thinks that I typed Format, AutoFormat. It
seems that while Excel is busy displaying the ToolTip, the fact that I typed C doesn’t make it into
the keyboard buffer. Microsoft actually had this fixed during the Excel 2010 beta, but they broke it
again in the Excel 2010 final version. If you slow down slightly, the Excel 2003 menu keys will
work more reliably. (It’s ironic that we have to work more slowly in Excel 2013-2019, isn’t
it?)Gotcha: The old keyboard shortcut Alt+H to open Help does not work anymore. Microsoft
decided that Alt+H would open the Home tab in all its products, so people who used to use the
menu shortcuts for Help are sunk. (Although… there wasn’t that much helpful on the old Help
menu. I can’t imagine anyone memorizing Alt+H, A to open the Help, About dialog.) The F1
keystroke still invokes help.Gotcha: Only some of the keystrokes from the old File menu continue
to work. Alt+F opens the File menu, where you are supposed to use the new shortcut keys. The
big three continue to work: Alt+F+O is File, Open, Alt+F+N is File, New. Alt+F+C is File, Close.
However, beyond that, you will find differences. In Excel 2003, using Alt+F+W would save a
workspace. In Excel 2013-2019, the same keystrokes take you to the Print menu. Go
figure.Additional Details: In addition to the Alt key shortcuts, the Ctrl key combinations from
previous versions of Excel still work: Ctrl+B is Bold, Ctrl+I is Italic, Ctrl+U is Underline, Ctrl+C is
Copy, Ctrl+X is Cut, Ctrl+V is Paste, Ctrl+5 is Strikethrough.In addition, any keystrokes that you
use while working in the grid continue to work. Ctrl+Down Arrow moves to the last row in the
current region. Ctrl+* selects the current region, the End+Right Arrow moves to the last column
in a contiguous range.The Function keys continue to work as well. F2 edits the current cell. F4
repeats the last command or adds dollar signs to the last reference when you’re entering a
formula. F11 continues to create a chart in one click, and the new Alt+F1 will create the same
chart as an embedded object.Use Keyboard Shortcuts to Access the RibbonProblem: I never
learned the Excel 2003 menu shortcuts. I would like to be able to use the keyboard to access
some of the most-used Excel commands.Strategy: The keyboard shortcuts for Excel allow you
to access almost everything on the ribbon and Quick Access toolbar. While the Quick Access
toolbar shortcuts are subject to change, the ribbon shortcuts are predictable and worth
learning.You can use the Alt key to access the ribbon tabs. Excel labels each tab of the ribbon
with a different letter. In the figure below, you can see that the letters F, H, N, P, M, and A will
allow you to access different tabs of the ribbon. The Quick Access toolbar shortcuts are
numbers 1 through 9, and then they start using two digits from 09 down to 01. You can type Alt
plus one of these letters to switch to a particular ribbon tab.Figure 37 Press the Alt key to display
these tooltips.After pressing Alt,H, Excel draws in new shortcut keys to access all of the
commands on the Home tab. In the figure below, you can see that C is Copy, F+P is Format
Painter, and F+O is the dialog launcher for the Clipboard group.Figure 38 FS stands for Font
Size. Why FK for Decrease Font Size?Some of these keyboard shortcuts are somewhat obvious;
for example, FS stands for Font Size and FF stands for Font Face. AL is Align Left. Other
keyboard shortcuts make sense in a historical context; for example, Ctrl+V has meant Paste for
25 years, so it seems natural to use V for Paste. Some of the shortcuts don’t seem to have any



rhyme or reason; I have no idea why H is used for fill colorIn some cases, a keyboard shortcut
leads to a new flyout menu or gallery. Some items in that menu will have shortcut keys. Others
might require using the arrow keys to select them.A few commands in Excel 2003 were difficult
to reach with the keyboard shortcuts. In Excel, you should be able to reach every command by
using the keyboard.Gotcha: Although it makes sense to memorize keyboard shortcuts for the
ribbon, it does not make sense to do so for the Quick Access toolbar. Every computer’s Quick
Access toolbar will be different, and your Quick Access toolbar will be different if you customize.
Although you can invoke Quick Access toolbar commands with the keyboard, it’s probably not
worth your time and effort to memorize them.Why Do I Have Only 65,536 Rows?Problem: Hey!
Microsoft said that the grid in Excel was massively large—1.1 million rows by 16,384 columns. I
opened my favorite Excel file, and I have only 65,536 rows. What’s going on?Figure 39 This
workbook only has 65,536 rows.Strategy: Files created in Excel 2003 and stored with an .xls
extension are opened in Compatibility mode. In this mode, you can only access the original grid
size.If you will not be using this file in Excel 2003 anymore, you should convert it to the new file
format. Open the File menu and choose Convert. Excel will update the file, save the file, close
the file, and reopen the file. You will have access to the entire grid.Additional Details: Excel’s
larger grid introduces an interesting problem. In Excel 2003, you might have a spreadsheet with
named ranges such as TAX15, ROI2019, and so on. These names are now actual cell
addresses! If you open a workbook that had these names defined and then convert to a new file
format, Excel will change the named range to _ROI2019 (with an underscore). While most of
your formulas will update, any functions that use the INDIRECT function or VBA code might
need to be manually updated.Which File Format Should I Use?Problem: I’ve been using .xls files
for years. What are these new .xlsx, .xlsm, .xlsb, xlam, and .ods file types? Which should I use?
Figure 40 XLSX is the ugly step-sister that won’t allow macros.Strategy: Excel 2003 used XLS, a
proprietary binary format. The old .xls binary file format could not handle data beyond row
65,536. So, the new .xlsb file format is a proprietary binary file format that can handle the 17
billion cells in Excel.The new .xlsm file format is an amazing file format. The entire spreadsheet
is saved as a series of text-based XML files, and then that collection of files is zipped into a
single file in order to save disk space. You can actually take a look at the insides of an .xlsm file.
In Windows Explorer, if you rename the file and add a .zip extension, you can then open the file
using any zip utility. This is a fairly exciting advancement because it means people will be able to
use third-party tools to generate Excel files without having Excel on their computers. However,
the .XLSM file takes a bit longer to open than .XLSB. My preference is .XLSM, but if you have
particularly large files to open, then .XLSB might save you some time.You can tell that security
issues have taken a grip on the people at Microsoft. They’ve introduced a new file format that
guarantees that there will be no macros inside. The .xlsx file format uses the same zipped file
structure as .xlsm but deletes any macros in the file. As someone who uses macros all the time, I
think this is a silly file format. I guess if you plan on doing everything manually in Excel and if you
never have any plans to learn how to dramatically increase your efficiency with Excel, then you



could adopt the .XLSX file format. Actually, if you fit into this category, you could use Google
Docs!.xlam is another new file format. Developers can deliver Excel add-ins in this file
format..ODS is a relatively new (2007) file format used across many different spreadsheet
programs. Originally developed by Sun Microsystems, there is now a committee who oversees
this format. It still isn’t quite perfect, as Microsoft points out that you can not robustly store track
changes information in this format. If there are pockets of people in your company who are using
spreadsheet programs other than Excel, this might be a good format for you.In case you are
working in an office where many people still use legacy versions of Excel, you can always use
the Save As command to save an Excel file as an Excel 97-2003 file format. Excel actually
supports saving to 27 different file formats, including CSV, DIF, SLK, and other specialized
formats.Additional Details: You will probably choose one file type and stick with it. I’ve been
using .xlsm files without issue for seven years. If you decide on one format, you can tell Excel to
always use that file format. To do so, you select File, Options, and in the left pane of the Excel
Options dialog, you choose the Save category. From the top dropdown, you select your favorite
file format, as shown here.Figure 41 Choose a different file formatWhy Does The File Menu
Cover The Entire Screen?Problem: I opened the File menu, and it covers my
worksheet.Strategy: This is the new Backstage View in Excel 2010. The theory is that all of the
commands on the File menu are things you do once your document is done. Since you no longer
need the feedback of seeing the command in the worksheet, Microsoft can fill the screen with
three panels of information. Those extra panels provide a better experience for printing and
recent files.When you open the File menu, Excel fills 100% of your screen with a three-panel
Backstage view. The left portion of the screen works like a left navigation bar. The middle portion
of the screen contains a variety of commands related to the choice from the left navigation bar,
and the right portion of the screen provides a view of the additional settings related to the
command.The left navigation bar of the Backstage view contains six commands and six
categories.When you invoke a command, the Backstage View closes and the command is
performed. When you open a category, two additional panels will appear offering more
choices.The commands are at the top and bottom of the left navigation bar: Save, Save As,
Open, and Close are at the top. Options and Exit are at the bottom.The middle entries of Info,
Recent, New, Print, Save & Send, and Help all lead to a two-panel display will more
commands.How Do I Close The File Menu?Problem: When I try to close the Excel File Menu,
my document closes.Strategy: Click another ribbon tab or press Esc to close the backstage view
and return to the worksheet. There are three separate places in the File menu that offer an “X”
that you would think would close the File menu. Unfortunately, all three of those “X” icons are for
closing the workbook.Increase the Number of Workbooks in the Recent Files ListProblem: I
routinely open the same 20 workbooks. How can I use the Recent Files list to make my life
easier?Strategy: You can show up to 50 recent workbooks. Go to File, Options, Advanced, Scroll
down to Display and choose Show The Number of Recent Workbooks.Figure 42 Change the
number of recent workbooks available.Gotcha: Although you can specify for the Recent



Documents list to show up to 50 files, the number of files it can actually show is limited by your
available screen space. If you have a 1440x900 monitor, as suggested in “Go Wide” on page 4,
you will have room for only about 36 files. Excel will not add a second column nor a scrollbar to
the Recent Documents to show more files.Additional Details: The grey thumbtacks to the right of
each workbook allow you to create favorites. Click the thumbtack to pin a workbook to the
Recent list. Say that you always use three workbooks during the accounting close. Over the
course of a month, you open hundreds of files so those three documents scroll out of the Recent
pane. By pinning them to the list, you will always have access to those documents in the Recent
list.Additional Details: The Recent Documents list in Excel 2019 works better than the Recently
Used File List in Excel 2003. The old list worked fine for files opened through File, Open, but it
failed to note files that were opened by double-clicking in Windows Explorer. Now, the Recent
Documents list will note files that are opened through Windows Explorer or even files opened
through a macro.Excel’s File menu might or might not show you Recent Workbooks. If you don’t
have another workbook open, clicking File will get you to the Recent pane. If another workbook
is open, you will see the Info pane instead. By using the second checkbox in the image above,
you can always see 9 recent documents in the File menu.Using the option in the figure above
allows you to use Alt+F+3 to open the third most recent document.Gotcha: If you are snooping
around in files that you should not be looking at, the Recent Documents list can be problematic.
The operation of the list changed since Excel 2003. It used to be that you could delete file 5 from
the list by changing the setting to 4 files and then back to 9 files. This would clear items 5
through 9 from the list. An “improvement” in Excel 2007 is that if you change the setting from 50
to 5 and then back to 50, Excel will immediately return to showing the last 50 items in the list. If
you are trying to hide your trail, you have to set the setting back to 0 files. This is the only way to
delete the file list from the cache.Change All Print Settings in ExcelProblem: Print settings
appear in many different places in Excel. I am never sure if I should go to Page Setup, the Print
dialog, or the Options button in the Print dialog.Strategy: Excel 2019’s File menu uses the Print
panel. Get there by using Ctrl+P or File, Print. This panel leverages all of the goodness of the
three-panel Backstage View.As shown below, the Print panel offers settings from the Print
dialog, Printer Options dialog, Page Setup dialog, and the Print Preview.Additional Details:
There are a few tricks to the Print pane. Look below the Print Preview on the right side of the
screen. Little icons there give you all of the functionality that you might have used in the legacy
print preview. The far right icon is Zoom. The icon to the left of zoom will draw the margins and
column width markers in so you can adjust them in the preview. Move to the next page using the
page control on the bottom left side of the Print Preview.Gotcha: If you don’t have a wide screen
monitor, and if your document is in landscape mode, you may not like the print preview in this
panel. Go back to the old Print Preview as discussed in the previous topic.Figure 43 Most of the
print settings in one place.Additional Details: The Settings section of the Print panel offers a new
type of control. Normally, you might have a dropdown called Orientation. You would open the
dropdown to see Portrait and Landscape and to see that one of those items is selected. The



Office team created a new control for this panel that shows you the current selected item. When
you open the dropdown, you see additional choices.Figure 44 The dropdown name shows you
what is selected.I Just Want The Old Print Preview BackProblem: I don’t like change. I don’t have
time to learn about the backstage view. I don’t like anything new. Just give me the old Print
Preview command.Strategy: Customize the Quick Access Toolbar as shown back near Figure
35. Choose All Commands from the left dropdown. Scroll down until you find Print Preview Full
Screen. Add this to the Quick Access Toolbar or to a Ribbon group.Microsoft left the Print
Preview Full Screen in Excel for people who write macros and need the macro to pause while
someone deals with the print preview settings. Using the icon above will allow you to use the old
familiar Print Preview.Figure 45 This is the old Print Preview.Get Quick Access to Formatting
Options Using the Mini ToolbarProblem: Why do I have to always go to the top of the window to
reach formatting commands? I loved having floating toolbars in Excel 2003. Why did Microsoft
get rid of them?Strategy: Excel now offers one floating toolbar, but it is elusive. Here’s how you
use it:1. Select some text in a chart. Look very closely above and to the right of the selection.
Excel draws in a nearly invisible Mini toolbar. (It may not even appear in the printed version of
this book.) Look for the Bold icon above the final “a” in Data in this figure.Figure 46 The Mini
toolbar starts out nearly invisible.2. Move the mouse toward the Mini toolbar. The Mini toolbar will
become more visible and will be available for use.Figure 47 Move the mouse toward the toolbar,
and it will solidify.Gotcha: If you generally select text by dragging the mouse from right to left, you
will never see the mini toolbar. I used Excel for months without ever causing it to
appear.Additional Details: If you move the mouse toward the Mini toolbar and then away, the
Mini toolbar will solidify and then disappear. You can keep making it appear and disappear, but if
you eventually get a certain number of pixels away from the toolbar, Excel will hide the toolbar
until you re-select the data.Additional Details: The Mini toolbar will appear often in Word. In order
for it to appear in an Excel cell, you have to select only a portion of the characters in the cell. In
this case, you will see an abbreviated version of the Mini toolbar.You can also cause the Mini
toolbar to appear if you select cells and right-click.What Is Protected Mode?Problem: Any time
that I download a file from our file sharing site, it opens in Protected mode.Strategy: I am sure
that you regularly get files from other people in your company. They arrive via Outlook or you
download them from an Internet site. I always worry that those people aren’t smart enough to
avoid getting viruses or that they actually hate me and would maliciously slip something bad into
the workbook_open macro to cause problems with my computer.In Excel 2003, if you opened a
file with a macro, it stopped right away and made you choose whether to enable or disable
macros. Have you ever thought about this question? How the heck should I know whether I
should enable the macros when I haven’t even had a chance to look around the worksheet (or
examine the macro code, if you are comfortable with that)?When you answered Enable Macros
in Excel 2003, you were really taking a risk.Now, any file that comes from a potentially
dangerous location is open in the new Protected mode in Excel 2010+. Here is the cool thing
about Protected mode: You can look at the workbook. You can scroll through it or go to other



worksheets. You can look at the macros. When you are convinced that the file is safe, you click a
button and the workbook is available in regular mode.This is brilliant. You get to actually look at
the workbook, and while doing so it cannot harm your computer. You get to make an educated
decision as to whether the workbook may prove harmful.And, you know what? A lot of the time,
you won’t even have to leave Protected mode. You can look at the worksheet, see what you
need to see, and close the workbook.If you need to edit the workbook, use the button shown in
here.Figure 48 When you are convinced that the workbook is safe, enable editing.Additional
Details: The following is a list of files that will open in Protected Mode. Any file that did not
originate on your computer can open in protected mode.Files that you download from the
InternetFiles in your temporary Internet folderFiles that you open from OutlookFiles that fail
validationIf you want to adjust those settings, click the words in the information bar in Figure 48,
and then choose Protected View Settings. You can turn off Protected mode for any of the
situations shown here.Figure 49 You can tweak which files open in Protected Mode.Use a
Trusted Location to Prevent Excel’s Constant WarningsProblem: Excel is more security-
conscious than in the past. In fact, many features that I rely on are now disabled, such as links to
external files, external queries, and macros.Strategy: Microsoft will ease up if you store your files
in a trusted location. Follow these steps:1. Store all your files with macros and data for links in a
folder on your hard drive. Make sure no viruses are in the folder. Delete any dragons, centaurs,
and grues from the folder. Make sure you don’t store your kid’s delete-all-files-on-the hard-drive
science project in that folder.2. Select File, Options. In the left pane of the Excel Options dialog,
choose Trust Center. Click the Trust Center Settings button. In the left pane, choose Trusted
Locations.3. Near the bottom, click the Add New Location button.4. In the Microsoft Office
Trusted Location dialog, click the Browse button. Browse to the correct folder and click
OK.Figure 50 Open anything from this folder without warnings.5. If you want the subfolders of
the location to be trusted as well, select the Subfolders of This Location Are Also Trusted check
box.6. Click OK to add the trusted location. Click OK to close the Trust Center. Click OK to close
the Excel Options dialog.Results: You will now be able to open files with links and external data
queries without a hassle, if they are in a trusted location.Additional Details: Microsoft is now
counting on you. Please, don’t randomly right-click on attachments in spam e-mails and choose
to save them in the trusted location.My Manager Wants Me to Create a NewExpense Report
from ScratchProblem: My manager wants me to design a new expense report completely from
scratch. It seems intimidating to create this report from scratch.Strategy: There are hundreds of
free prebuilt documents available to registered owners of Excel, so “starting from scratch” isn’t
as frightening as it might seem. When you select File, New and then select a category from the
list at the left, Excel will show you all the available documents. To use a document, you click the
thumbnail and choose Download.Figure 51 Get free templates from the New File
dialog.Additional Details: The variety of documents available is amazing. For instance, choose
More Categories from the left, and you can access identification cards, games, fantasy football
trackers, scorecards, and tournament brackets. Before you design a new form, see if Excel has



such a form already available.Gotcha: This feature is available only to people who own legitimate
copies of Excel. If you are using a pirated version, you cannot access the templates.Open a
Copy of a WorkbookProblem: I have a workbook called invoice.xlsm. I want to keep the original
file unchanged and save each new version as a new workbook. However, I tend to forget to use
Save As, so I often overwrite this workbook.Strategy: When using the Open command, you can
specify that you want to open the file as a copy. Here’s how you take advantage of this option:1.
Instead of clicking the Open button to open a file, click the dropdown arrow next to the Open
button. Choose Open as Copy. The file that opens will be named Copy (1) of invoice.xlsm.2.
Select File, Save As to save the file with a new name. Note that even if you forget to use Save
As, at least you will not overwrite the original invoice.xls.Figure 52 Open as Copy to prevent
saving over the original.Open Excel with Ctrl+Alt+XProblem: I love keyboard shortcuts in Excel.
Why isn’t there a keyboard shortcut to open Excel?Strategy: You can assign a keyboard shortcut
to Excel.Go to your Start menu and find the icon for Excel. Right-click the icon and choose
Properties. In the properties dialog, there is a Shortcut Key box. Click in the box and type Ctrl+Alt
+X. Click OK.Figure 53 Assign a shortcut key to the program.You can now launch Excel with Ctrl
+Alt+X. You might wish to add other shortcuts, such as Ctrl+Alt+N for Notepad++, and so
on.Have Excel Always Open Certain Workbook(s)Problem: I always use Excel to work on a
particular workbook. Every time that I open Excel, I want this workbook to open
automaticallyStrategy: You can place the file you want to always open (or a shortcut to the file) in
the XLStart folder, which is generally found in the %AppData%\Microsoft\Excel\ folder. Anything
in this folder will automatically start when Excel starts.Alternate Strategy: You can specify one
folder to act as an additional XLStart folder. Follow these steps:1. Move the Excel workbook or
workbooks to a new folder. Excel will try to open every file in this folder, so make sure you do not
have other files in it.2. Open Excel. Select File, Options.3. Click Advanced in the left pane of the
Excel Options dialog.4. Scroll down to the General section. Enter the path to the folder from step
1 in the At Startup, Open All Files In text box, as shown here.Figure 54 Any workbooks in this
path open when you open Excel.Alternate Strategy: Another strategy is to use a command-line
switch, as discussed in “Set Up Excel Icons to Open a Specific File on Startup.”Set up Excel
Icons to Open a Specific File on StartupProblem: I routinely use the same five files in my job. I
want a series of five icons on my Desktop so I can easily open these five files.Strategy: You can
use a startup switch in the shortcut. Excel offers startup switches to open a specific file, to open
a file as read-only, to suppress the startup screen, or to specify an alternate default file location.
Follow these steps.1. Open Windows Explorer using Win+M.2. Browse to %ProgramFiles%
\Microsoft Office\Office16\3. If Windows Explorer is in full-screen mode, click the Restore Down
button so you can see the desktop.4. Scroll down to the Excel.exe entry. Right-click and drag it to
the Desktop.5. Choose Create Shortcuts Here from the menu that appears when you release the
right mouse button.6. On the Desktop, right-click the new Shortcut to Excel icon and choose
Properties.7. In the Properties dialog, choose the General tab.8. Change the name in the top text
box to something meaningful. If this icon will be used to open the Sales file, for example, a short



name like Sales would work.9. On the Shortcut tab, locate the Target field. As you can see
below, this field contains the complete path and file name to EXCEL.EXE, with the path and file
name enclosed in quotation marks. (The Target field is not big enough to display the entire path,
so you must click in the field and press the End key in order to see the end of the entry.)Figure
55 Use the End key to move to the end of the field.10. After the final quote in the Target field,
type a space and the path and file name.You can now click that icon to open the particular Excel
file.Use a Macro to Customize StartupProblem: Every time I open a workbook, I would like to put
the file in Data Form mode or invoke another Excel menu as the file opens.Figure 56 The data
form is increasingly difficult to find in Excel.Strategy: Startup switches can only do so many
things. You will have to use a Workbook_Open macro in order to force Excel into Data Form
mode. Follow these steps:1. In Excel, type Alt+T followed by M and S.2. Choose Disable All
Macros with Notification. Click OK.3. Open your workbook.4. Press Alt+F11 to open the VBA
Editor. Gotcha: The Microsoft Natural Multimedia keyboard does not support the use of Alt
+function keys. You might have to type Alt+T followed by M and D.5. Press Ctrl+R to show the
Project Explorer in the upper-left corner. You should see something that looks like VBAProject
(Your BookName) in the Project Explorer.Figure 57 Click the + to expand the project.6. If there is
a + to the left of this entry, press the + to expand it. You will see a folder underneath, called
Microsoft Excel Objects. If there is a + to the left of this entry, press the + to expand it, also. You
will now see one entry for each worksheet, plus an entry called ThisWorkbook.7. Right-click
ThisWorkbook and choose View Code from the context menu.8. Copy these three lines of code
to the large white code window:Private Sub Workbook_Open()ActiveSheet.ShowDataFormEnd
Sub9. Press Alt+Q to return to Excel.10. Select File, Save As, Excel Macro-Enabled
Workbook.11. Close the file.12. Open the file. The information bar tells you that macros have
been disabled.13. Select Options, Enable This Content. The data form will open.Alternate
Strategy: To prevent Excel from automatically disabling macros, you can save the file in a trusted
location. See “Use a Trusted Location to Prevent Excel’s Constant Warnings” earlier in this
section.Gotcha: The data form used to be an option on the Excel 2003 Data menu. It is hidden in
Excel today. To invoke this command, you can either press Alt+D+O or add the command to your
Quick Access toolbar.Additional Details: The simple Workbook_Open macro invokes a Menu
command. It is possible to build highly complex macros that would control literally anything. For
a primer on macros, consult from Que Publishing.Control Settings for Every New Workbook and
WorksheetProblem: Every time I start a new workbook or insert a new worksheet, I always make
the same customizations, such as setting print scaling to fit to one page wide, setting certain
margins, adding a “Page 1 of n” footer to the worksheet, making the heading row bold, and so
forth. How can I have these settings applied to every new workbook or worksheet?Strategy: Two
files control the defaults for new workbooks and inserted worksheets. You can easily customize a
blank workbook to contain your favorite settings and then save the file as book.xltx and
sheet.xltx. Then, any time you either click Ctrl+N for a new workbook or insert a worksheet, the
new book or sheet will inherit the settings from these files. Follow these steps to create



book.xltx:1. In Excel, open a new blank workbook with Ctrl+N.2. Customize the workbook as you
like. Feel free to make adjustments to any of the following:Page layout settingsThe print areaCell
stylesFormatting commands on the Home tabData, Validation settingsThe number and type of
sheets in the workbookThe window view options from the View tab3. Decide where you want to
save the file. This can be either in the XLStart folder (generally C:\Program Files\Microsoft Office
\Officenn\XLStart) or in the alternate startup folder. (See “Have Excel Always Open Certain
Workbooks”.)4. Select File, Save As, Other Formats.5. In the Save As dialog, open the Save as
Type dropdown and choose Excel Template (*.xltx).6. Browse to the XLStart folder you specified
in step 3.7. Save the file as book.xltx.Results: All subsequent new workbooks created with Ctrl
+N will inherit the settings from the book.xltx file.Gotcha: Excel 1 through Excel 2003 had a
“New” icon on the Standard toolbar and a “New…” icon on the File menu. While these icons
sound similar, they are very different. The regular “New” icon will create a new workbook based
on book.xltx. The “New…” icon leads to a panel where you can select a template from Office
Online. This trick will not work with the File, New command in Excel 2010. You have to use Ctrl
+N or add the old “New” icon to the QAT or ribbon. The problem is worse in Excel 2013, where
the Blank Workbook tile offered on the Start Screen is equivalent to “New…” and will not load
Book.xltx.Additional Details: You should also set up a workbook with one worksheet and save
this workbook as sheet.xltx. All inserted worksheets will inherit the settings from this
file.Additional Details: If you regularly create macros, save the files with the .xltm extension
instead.Excel Says I Have Links, But I Can Not Find ThemProblem: When I open a workbook,
Excel tells me there are external links in the file. Where are they?Strategy: Use Ctrl+F to open
the Find dialog. Open the Options>> button and change the Within dropdown from Sheet to
Workbook. Search for a left square bracket. If the links are in a formula in a cell, this technique
will find the link. If nothing is found, then go to Formulas, Name Manager. Links are often lurking
in out-of-use named ranges. I’ve also seen links hiding in the Data, Consolidate dialog box.If you
want to break the links or change the source to a new location, open the File menu. On the right
side of the screen, look for Related Documents and click the Edit Links to Files hyperlink.Figure
58 Break links or change the source file.Automatically Move the Cell Pointer After EnterProblem:
If I type a number and then press a direction arrow key, Excel will enter the number and move
the cell pointer in the direction of the arrow key. However, if I am using the numeric keypad, it is
much more convenient to use the Enter key on the numeric keypad than to use the arrow keys.
By default, Excel will move the cell pointer down one cell when I press Enter. Is there a way to
have Excel automatically move the cell pointer to the next cell to the right after each entry?
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